[Libreoffice] Problem with build environment: Gtk-linkage error

Albert Thuswaldner albert.thuswaldner at gmail.com
Tue Apr 5 13:47:00 PDT 2011

Hi Kayo/List

> So I believe that this can be your problem, zypper si -d
> libreoffice-bootstrap (or OpenOffice_org-bootstrap) will install the sources
> that LibreOffice needs to build[1], not the source of libreoffice-bootstrap.
> [1] -
> http://wiki.documentfoundation.org/Development/Linux_Build_Dependencies
> Do it and try to compile again.

Ok, just to give feedback on this:

1.) I installed the dependencies as you (Kayo)  wrote (missed that
part of the wiki instructions) however as expected I had most of the
packages installed already (only some mono-stuff got installed). I
also pulled down a new bootstrap and pulled the rest of the sources
with 'make fetch', so I had an absolutely untainted build tree.
Compiled using 'make 2>&1 | tee build.log' => same error!

2.) For the record I regularly build emacs (gtk) from source, and I
never had any problems with gtk linking there.

3.) Tried  to add '--disable-unix-qstart' as argument to ./autogen
since my problem seems to relate to that part of the code => same
error. The disable flag does not work?

4.) So I gave up on gtk and run './autogen.sh --with-num-cpus=2
--with-max-jobs=2 --without-junit --disable-unix-qstart --disable-gtk
--enable-kde4', which compiled sucessfully. Also 'make dev-install'
works. However when starting libreoffice it crashes with the dialog
box "Fatal Error",  "the application can not be started.
[context="shared"] caught unexpected exception!" (BTW shouldn't it be
"caught an unexpected exception!" ?)

5.) So any hints on how I can debug this error further would be much
appreciated. What tools to use? What methods/tutorials to follow?



More information about the LibreOffice mailing list