[Libreoffice] Build failed in sfx2 in -3-3 branch

Petr Mladek pmladek at suse.cz
Fri Jun 17 04:08:34 PDT 2011

Korrawit Pruegsanusak píše v Čt 16. 06. 2011 v 22:51 +0700:
> Hello all,
> I was trying to build libreoffice-3-3 branch, but it failed in sfx2 module.
> (I was trying to fix fdo#30550)
> I think the related build log would be:
> ... (near the first start of log)
> > Fetching dependencies for module l10n from solver... failed
> > Fetching dependencies for module libegg from solver... failed
> ...
> > Compiling: sfx2/source/appl/shutdowniconunx.cxx
> > /home/korrawit/libo/clone/libs-core/sfx2/source/appl/shutdowniconunx.cxx:11:33: error: eggtray/eggtrayicon.h: No such file or directory
> Then resulted in an error.
> Also, I was tried to build sfx2 alone, and it resulted in the same error.

This header should be provided by the module "libegg". Please, make sure
that this module is built and delivered.

I see the following in sfx2/prj/build.lst

--- cut ---
sf      sfx2    :    l10n idl basic xmlscript framework readlicense_oo
shell setup_native sax SYSTRAY_GTK:libegg LIBXML2:libxml2 NULL
--- cut ---

So, the module libegg is built only when SYSTRAY_GTK is enabled.

You might also try to use --disable-systray configure option. You will
not have the systray icon in GNOME but it is not needed for fixing that
bug. The icon is disabled at runtime by default anyway.

Best Regards,

More information about the LibreOffice mailing list