[Libreoffice] Duplicate code: SwDoc::SplitDoc

Chr. Rossmanith ChrRossmanith at gmx.de
Sun May 8 14:08:08 PDT 2011


there are two slightly different implementations of SwDoc::SplitDoc(), 
depending on the third parameter given. As far as I can see they only 
differ in the way pSttNd (what stands Stt for?) and pEndNd are found. If 
that's true, I'd suggest to have two different GetEndNode() and 
GetSttNode() methods and only one

SplitDoc(sal_uInt16 eDocType,  const String& rPath, const SwTxtFmtColl* 
pSplitColl, int nOutlineLevel)

with either pSplitColl OR nOutlineLevel passed as parameter but not 
both. Would that be bad coding style? On the other hand, are ~200 lines 
of identical code good style? Any suggestions how to get rid of the 
duplicates else?


More information about the LibreOffice mailing list