[Libreoffice] [GSOC][Urgent] Build fails

Michael Meeks michael.meeks at novell.com
Mon May 9 01:38:29 PDT 2011

Hi there,

On Mon, 2011-05-09 at 07:19 +0530, Anurag Jain wrote:
> I tried to update my Lo clone and ended up with failed build for vcl
> and odx modules. Here are the partial build outputs.

	Thanks for the great log output; this means:

./unxlngi6.pro/slo/abstdlg.o: file not recognized: File truncated
collect2: ld returned 1 exit status
dmake:  Error code 1, while making '../unxlngi6.pro/lib/libvclli.so'

	That you have a zero sized file in there in error - perhaps you aborted
the build, or re-set your machine mid-flow or something, or your
compiler didn't do a great job:


	I would remove that file; and or rm -Rf vcl/unxlngi6.pro to be on the
safe side.

	I'd do something similar in odk: notice the build messages recommend

rm -Rf /home/victor/git/libo/odk/unxlngi6.pro # optional module 'clean'

	Have you tried that ?

	All the best,


 michael.meeks at novell.com  <><, Pseudo Engineer, itinerant idiot

More information about the LibreOffice mailing list