[Libreoffice] Make check now fails on master in smoketest for Mac OSX

Alexander Thurgood alex.thurgood at gmail.com
Fri May 13 00:49:36 PDT 2011


I built from master on Mac OSX 2 days ago, make check worked, and
smoketest successfully did its tests, i.e. I saw the app start, a window
opens briefly, then closes again, and this is repeated a couple of
times. Note that I built initially with the LANG switch "en-US, de, fr, ru".

Now, after pulling all the latest changes into the repo, the build still
completes and packages, but when I attempt a make check, the build fails
in smoketest, and its attempt to start the office gets the splashscreen,
and then a laconic error message in French :

LibreOffice 3.4 - Fatal Error
"Impossible de lancer l'application"
with a ~OK button to close.

Rebuilding the module specifically after a rm leads to the same result.

Something changed ? Thorsten, the patch to the cppunit tests to avoid
the locale problem ?

FWIW, the app installs from the DMG and starts normally, so does the
problem lie somewhere in the way the smoketest bootstraps the office to
start ?


More information about the LibreOffice mailing list