widget layout progress
noelgrandin at gmail.com
Mon Aug 20 09:39:15 PDT 2012
On Mon, Aug 20, 2012 at 6:03 PM, Caolán McNamara <caolanm at redhat.com> wrote:
> Making a bit of progress in widget layout.
> [*] maybe the cast-happy syntax looks a bit vile. Perhaps a bit family
> of get_foos_by_name, or a get_by_name<T> template instead ?
How about get_VclContainer, get_CheckBox, etc ?
It's a library class, so it's supposed to make the client code easier
to use, even at the cost of introducing some extra weight into itself.
And it's not like there are lots of different ways of extracting the
widgets, so the "by_name" is unnecessary IMNSHO :-)
More information about the LibreOffice