Missing sane/sane.h check

Robert Peters r2p2.gw at gmail.com
Thu Dec 27 17:20:15 PST 2012


as mentioned in this bug report
https://bugs.freedesktop.org/show_bug.cgi?id=56158 build problems
should be
communicated over the mailing list. So do I.

I never tried to build LibreOffice before on my machine, so that the
configure script had many complaints about
missing dependencies I had to install. Done so, make fetched some
additional stuff from the web and
started to compile.

After a long time make complained about an compiler error because
sane/sane.h was not found. After installing
libsane-dev it continues compiling.

I took a look into configure.ac which actually contains an check for
sane/sane.h. But if I see this correct it will
be only executed if --with-system-sane is passed.

(Please excuse the german output. Forgot to change locale settings
before. But it doesn't say more than I did above.)
[build CXX] extensions/source/scanner/sane.cxx
[build CXX] extensions/source/scanner/sanedlg.cxx
In file included from
schwerwiegender Fehler: sane/sane.h: Datei oder Verzeichnis nicht
Kompilierung beendet.
make[1]: *** [/mnt/private/development/cpp/LibreOffice/workdir/unxlngx6.pro/CxxObject/extensions/source/scanner/sane.o]
Fehler 1

best regards
Robert Peters

PS: Tried to build: c318f3b0224a57102614be0efec4b49c80a3aa82

More information about the LibreOffice mailing list