qa-build errros on clean code

Markus Mohrhard markus.mohrhard at
Tue Feb 14 23:11:11 PST 2012


> I am experiencing problems with building (openSUSE 12.1).
> I have two machine that can build the code.
> One of the machines started acting up last weekend with assertions from
> sc/qa/unit/ucalc.cxx  when performings tests. Removing all my changes and
> updating the code (./g pull -r) does not help. I used with
> parameters with-max-jobs=6 --with-num-cpus=6 --without-junit
>  --enable-dbgutil (and sometimes --enable-debug).
> I even produced a brand new clone with git; same error.
> The other produced an error after ./g pull -r yesterday. On this one I used
> with parameters with-max-jobs=1 --with-num-cpus=1 --without-junit
>  --enable-dbgutil.
> The error message is:
> /home/w.donkers/git/libo/sw/qa/extras/rtftok/rtftok.cxx: In member function
> 'void RtfModelTest::testFdo45543()':
> /home/w.donkers/git/libo/sw/qa/extras/rtftok/rtftok.cxx:159:5: error: no
> matching function for call to 'assertEquals(int, sal_Int32,
> CppUnit::SourceLine, const char [1])'

Tor already fixed it and after a pull you should be able to build.

Hope that your next build succeeds.


More information about the LibreOffice mailing list