[Libreoffice] Android bitlets ...

Michael Meeks michael.meeks at suse.com
Wed Jan 18 10:32:13 PST 2012

Hi there,

	Playing with the android stuff some more, I got quite a bit further;
but had a few problems - thought it's prolly better to ask on the
archived list for help:

	* size of /data too small: (default seems to be 54Mb or so)

make install:
Installing /home/opt/libreoffice/devel/android/qa/sc/bin/sc-debug.apk
onto default emulator or device...
     [exec] 3856 KB/s (32230207 bytes in 8.162s)
     [exec] 	pkg: /data/local/tmp/sc-debug.apk

	I tried to fiddle with the avd creator at great length to make /data
bigger, only succeeding in making it crash on boot in a loop ;-)

	In the end I did:

adb shell
mkdir /mnt/sdcard/tmp
mount -o bind /mnt/sdcard/tmp /data/local/tmp

	And it installed: not beautiful, but ... what do you do ? there must be
a better way (surely) :-)

	* running it I get logcat to show me:

I/ActivityManager(   77): Start proc org.libreoffice.android.qa.sc for activity org.libreoffice.android.qa.sc/org.libreoffice.android.Bootstrap: pid=594 uid=10040 gids={}
I/dalvikvm(  594): Turning on JNI app bug workarounds for target SDK version 9...
W/NetworkManagementSocketTagger(   77): setKernelCountSet(10040, 1) failed with errno -2
V/TabletStatusBar(  130): setLightsOn(true)
W/dalvikvm(  594): Exception Ljava/lang/UnsatisfiedLinkError; thrown while initializing Lorg/libreoffice/android/Bootstrap;
W/dalvikvm(  594): Class init failed in newInstance call (Lorg/libreoffice/android/Bootstrap;)
D/AndroidRuntime(  594): Shutting down VM
W/dalvikvm(  594): threadid=1: thread exiting with uncaught exception (group=0x409961f8)
E/AndroidRuntime(  594): FATAL EXCEPTION: main
E/AndroidRuntime(  594): java.lang.ExceptionInInitializerError
E/AndroidRuntime(  594): 	at java.lang.Class.newInstanceImpl(Native Method)
E/AndroidRuntime(  594): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
E/AndroidRuntime(  594): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
E/AndroidRuntime(  594): 	at dalvik.system.NativeStart.main(Native Method)
E/AndroidRuntime(  594): Caused by: java.lang.UnsatisfiedLinkError: Couldn't load lo-bootstrap: findLibrary returned null
E/AndroidRuntime(  594): 	at java.lang.Runtime.loadLibrary(Runtime.java:365)
E/AndroidRuntime(  594): 	at java.lang.System.loadLibrary(System.java:535)
E/AndroidRuntime(  594): 	at org.libreoffice.android.Bootstrap.<clinit>(Bootstrap.java:207)
E/AndroidRuntime(  594): 	... 15 more
I/ARMAssembler(   36): generated scanline__00000077:03515104_00009002_00000000 [127 ipp] (149 ins) at [0x41c86450:0x41c866a4] in 1748431 ns
W/ActivityManager(   77):   Force finishing activity org.libreoffice.android.qa.sc/org.libreoffice.android.Bootstrap

	Which puzzles me a little - could this be related to my previous

	* building fails with missing local.properties errors

	+ to fix this I ran:

cd android/qa/sc
/opt/libreoffice/android-sdk-linux/tools/android update project -n sc -t android-12 -p `pwd`
cd android/Bootstrap
/opt/libreoffice/android-sdk-linux/tools/android update project -n Bootstrap -t android-12 -p `pwd`

	Presumably that's utterly wrong ;-) but ... it got me a bit further.

	Do we need to have a --with-android-sdk parameter for configure too,
and add some of that stuff to the Makefile(s) as well ?

	* android/qa/simple

	I tweaked this to use the new Makefile defines, and tried to adapt it
to some new paths (sal got gnu-make-ised in the meantime eg.). Almost
certainly I broke it in the process.

	Hopefully I can get to some more fixing (or breaking depending how you
look at it) tomorrow. I believe I managed to commit my first half-arsed
version of an android VCL backend by accident: which does nothing at all
really except avoid the plugadapt thing - that could be the cause too.

	More debugging tips much appreciated etc.

	Thanks !


michael.meeks at suse.com  <><, Pseudo Engineer, itinerant idiot

More information about the LibreOffice mailing list