[Libreoffice] Compiling question by a complete beginner

Bruno Girin brunogirin at gmail.com
Sun Jan 22 04:55:48 PST 2012

On 21/01/12 20:49, Bar?s, Akkurt wrote:
> Hi, I'm a complete beginner in LibreOffice development and at the 
> compiling step now. I tried instructions here: 
> http://wiki.documentfoundation.org/Development/Native_Build But 
> compilation failed while building the moz module. I tried instructions 
> here: https://www.libreoffice.org/bugzilla/show_bug.cgi?id=39852 but 
> the result is the same.
> Then, i found this blog post and restarted compilation from the 
> beginning: 
> http://www.vogella.de/blog/2011/02/10/how-to-compile-libreoffice/ I 
> got an error about helpcontent2.
> Error message:
> -----------------------------------------------------------------------------------------------------------------------------------------------------------
> ERROR: error 65280 occurred while making 
> /home/baris/libo/helpcontent2/source/auxiliary
>  it seems that the error is inside 'helpcontent2', please re-run build
>  inside this module to isolate the error and/or test your fix:
> -----------------------------------------------------------------------
> rm -Rf /home/baris/libo/helpcontent2/unxlngi6.pro 
> <http://unxlngi6.pro> # optional module 'clean'
> /bin/bash
> cd /home/baris/libo
> source ./Env.Host.sh <http://Env.Host.sh>
> cd helpcontent2
> build
> when the problem is isolated and fixed exit and re-run 'make' from the 
> top-level
> -----------------------------------------------------------------------------------------------------------------------------------------------------------
> I tried ./autogen.sh --with-languages and ./download and the commands 
> above but, result is negative. I have directories such as artwork, 
> base, calc in clone directory but i have no l10n directory there.
> By the way, second way of compilation took 20 hours until the error. 
> Isn't this a bit long? The first one took only 8-9 hours.
> I'm using Ubuntu 11.04. Do you have any suggestions? Thanks, in advance.

Hi Baris,

I had exactly the same problem with Ubuntu 11.10 and it appears that for 
some reason moz doesn't build on Ubuntu. This was reported on this list 
in October: 

Now considering that moz is used for macro security settings and digital 
signatures, it's not essential to build it in order to have a working 
build. You can disable it as explained here: 

In my case for instance, I run the following to get it to build:
./autogen.sh --with-num-cpus=4 --disable-mozilla

Happy building!

> _______________________________________________
> LibreOffice mailing list
> LibreOffice at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/libreoffice

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/libreoffice/attachments/20120122/c95af3cf/attachment.htm>

More information about the LibreOffice mailing list