Using system libsqlite3.dylib on Mac OS X? (fdo#50682)

Stephan Bergmann sbergman at
Wed Jun 20 02:37:48 PDT 2012

Hi all,

<> "On MacOS X 10.7, 
'import uno' crashes in the LibreOffice-provided Python" discusses a 
problem that is due to our "official" LO Mac OS X builds (based on 10.4 
SDK) bringing along their own copy of libsqlite3.dylib instead of using 
the system one (if any).

I recently also ran into that problem when trying to build LO on Mac OS 
X 10.7 with Xcode 4 (see 
<> "Building 
on Mac OS X 10.7") and fixed it with 
"Make PyUNO work --with-macox-version-min-required=10.6" for that 
specific scenario.  At least when trying a resulting build on a Mac OS X 
10.7.4 machine, I did not notice any problems with switching to the 
system libsqlite3.dylib (but I did not check out any LO functionality 
that depends on that lib; I only verified that 
" -c 'import uno'" worked again).

Can anyone with access to a baseline Mac OS X 10.4 system check whether 
adapting this fix to always build against system libsqlite3.dylib on Mac 
OS X would work?  (And does anybody know what LO functionality would 
need to be checked for regressions?)


More information about the LibreOffice mailing list