GSoC & error during make

Mariana Marasoiu mariana.marasoiu at
Wed Mar 7 15:00:16 PST 2012

On Wed, Mar 7, 2012 at 7:17 PM, Mariana Marasoiu
<mariana.marasoiu at> wrote:
> I did yesterday a ./g pull -r but it didn't fix the build. Afterwards,
> I tried a make clean & make, which ended with the same result.
> I followed Korrawit's instructions and realised that the branch I was
> trying to build wasn't the master, but libreoffice-3-5. So I switched
> to master, did ./g pull -r and now it's building once again. Lets hope
> this time works :D

Okay, bad news... I still couldn't build LibreOffice :(.
It fails in two modules: officecfg and sal. I tried building them
separately, with a make clean before that, but I still get errors...

This is what I get for officecfg:

cd officecfg && make -j 1 -rs gb_PARTIALBUILD=T
[ build XCS ] officecfg/registry/schema/org/openoffice/Setup.xcs
parser error : Document is empty

parser error : Start tag expected, '<' not found

cannot parse /home/mariana/Working/git/libo/solver/
make[1]: *** [/home/mariana/Working/git/libo/workdir/]
Error 4
make: *** [officecfg] Error 2

And for sal module, there are lots of C++ errors and warnings and also
"No such file or directory" errors.
If I should post the output, tell me and I'll put it in a pastebin.

Mariana Mărășoiu

More information about the LibreOffice mailing list