GSoC & error during make

Michael Stahl mstahl at
Thu Mar 8 03:05:02 PST 2012

On 08/03/12 00:00, Mariana Marasoiu wrote:
> Okay, bad news... I still couldn't build LibreOffice :(.
> It fails in two modules: officecfg and sal. I tried building them
> separately, with a make clean before that, but I still get errors...
> This is what I get for officecfg:
> cd officecfg && make -j 1 -rs gb_PARTIALBUILD=T
> [ build XCS ] officecfg/registry/schema/org/openoffice/Setup.xcs
> /home/mariana/Working/git/libo/solver/
> parser error : Document is empty

this is a known problem when using make 3.81 and is fixed on master now:

please pull again and then do "rm -rf solver workdir" to remove the
broken stuff (or a top-level make clean).

Matus promises to test future build system changes that add new pattern
rules on all supported make versions before pushing  :)

> And for sal module, there are lots of C++ errors and warnings and also
> "No such file or directory" errors.

that problem had the same cause.

More information about the LibreOffice mailing list