[Libreoffice-commits] .: Branch 'feature/gbuild_testtools' - Repository.mk ...
David Ostrovsky
david.ostrovsky at gmx.de
Wed May 16 14:41:11 PDT 2012
Hi David,
well it was not ready yet ;-)
Anyway, thanks for your comments.
>>+TTUS := $(call gb_CustomTarget_get_workdir,testtools/uno_services)
>Please, do not do that. Just use
>$(call gb_CustomTarget_get_workdir,testtools/uno_services) where
>necessary.
This one I really don't understand. First we have already 30 cases, where this syntax is used:
[david at wizball libo (feature/gbuild_testtools *)]$ find . -name
"Custom*.mk" -exec grep ":=.*gb_CustomTarget_get_workdir" {} \; | grep
-v uno_services | wc -l
30
and second this form ist pretty short and more readable ...
Regards
David
On 15.05.2012 07:11, David Tardon wrote:
> On Mon, May 14, 2012 at 03:57:31PM -0700, David Ostrovsky wrote:
>> Repository.mk | 4 +
>> testtools/CustomTarget_bridgetest_climaker.mk | 65 ++++++++++++++++++++++++++
>> testtools/CustomTarget_uno_services.mk | 60 ++++++++++++++++++++++++
>> testtools/Library_bridgetest.mk | 59 +++++++++++++++++++++++
>> testtools/Library_constructors.mk | 55 ++++++++++++++++++++++
>> testtools/Library_cppobj.mk | 59 +++++++++++++++++++++++
>> testtools/Module_testtools.mk | 25 +++++++---
>> testtools/Rdb_cppobj.mk | 33 +++++++++++++
>> testtools/StaticLibrary_bridgetest.mk | 49 +++++++++++++++++++
>> 9 files changed, 403 insertions(+), 6 deletions(-)
>>
>> New commits:
>> commit 32124ca1fee5bb39486decf406ed404cc4aab6ae
>> Author: David Ostrovsky<David.Ostrovsky at gmx.de>
>> Date: Tue May 15 00:55:02 2012 +0200
>>
>> bridgetest further targets migrated
>>
>> Change-Id: I9e1b13b8f0454aa65d3b0b6a0b26e54bd2b3a21f
>>
>> diff --git a/testtools/CustomTarget_uno_services.mk b/testtools/CustomTarget_uno_services.mk
>> new file mode 100644
>> index 0000000..570cc14
>> --- /dev/null
>> +++ b/testtools/CustomTarget_uno_services.mk
>> @@ -0,0 +1,60 @@
>> +TTUS := $(call gb_CustomTarget_get_workdir,testtools/uno_services)
> Please, do not do that. Just use
> $(call gb_CustomTarget_get_workdir,testtools/uno_services) where
> necessary.
>
>> +#$(call gb_CustomTarget_get_target,i18npool/localedata) : \
>> +# $(patsubst %.xml,$(IPLD)/localedata_%.cxx, \
>> +# $(notdir $(wildcard $(SRCDIR)/i18npool/source/localedata/data/*.xml)))
>> +
>> +#$(IPLD)/localedata_%.cxx : $(SRCDIR)/i18npool/source/localedata/data/%.xml \
>> +# $(IPLD)/saxparser.rdb $(call gb_Executable_get_target_for_build,saxparser)
>> +# $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),SAX,1)
>> +# $(call gb_Helper_abbreviate_dirs_native, \
>> +# $(call gb_Helper_execute,saxparser) $* $< $@.tmp \
>> +# $(call gb_Helper_make_url,$(IPLD)/saxparser.rdb) \
>> +# $(call gb_Helper_make_url,$(OUTDIR_FOR_BUILD)/bin/types.rdb) \
>> +# -env:LO_LIB_DIR=$(call gb_Helper_make_url,$(gb_Helper_OUTDIR_FOR_BUILDLIBDIR)) \
>> +# $(if $(findstring s,$(MAKEFLAGS)),> /dev/null 2>&1)&& \
>> +# sed 's/\(^.*get[^;]*$$\)/SAL_DLLPUBLIC_EXPORT \1/' $@.tmp> $@&& \
>> +# rm $@.tmp)
> I am pretty sure this is just copy-and-paste leftover that we do not
> actually need there .-)
>
>> +
>> +$(TTUS)/uno_services.rdb : $(TTUS)/uno_services.input \
>> + $(gb_XSLTPROCTARGET) $(SOLARENV)/bin/packcomponents.xslt
>> + $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),RDB,1)
>> + $(call gb_Helper_abbreviate_dirs_native, \
>> + $(gb_XSLTPROC) --nonet --stringparam prefix $(OUTDIR_FOR_BUILD)/xml/ \
>> + -o $@ $(SOLARENV)/bin/packcomponents.xslt $<)
>> +
>> +$(TTUS)/uno_services.input :| $(TTUS)/.dir
>> + $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),ECH,1)
>> + echo '<list>$(my_components:^"<filename>":+".component</filename>")</list>'> $@
> This serves no purpose, because you can use the .component files
> directly. So, it seems this custom target can be removed entirely :-)
>
>> diff --git a/testtools/Rdb_cppobj.mk b/testtools/Rdb_cppobj.mk
>> new file mode 100644
>> index 0000000..0f35627
>> --- /dev/null
>> +++ b/testtools/Rdb_cppobj.mk
>> @@ -0,0 +1,33 @@
>> +
>> +$(eval $(call gb_Rdb_Rdb,cppobj))
>> +
>> +$(eval $(call gb_Rdb_add_components,cppobj,\
>> + testtools/source/bridgetest/cppobj \
>> +))
> IIRC the service rdb files generated by this class are only usable for
> installation, which we do not need. Just use the components directly.
>
> D.
> _______________________________________________
> LibreOffice mailing list
> LibreOffice at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/libreoffice
More information about the LibreOffice
mailing list