[PUSHED] fdo#48317 Help content for next/previous change navigation

Miklos Vajna vmiklos at suse.cz
Thu Nov 29 08:08:22 PST 2012

Hi Muhammad,

On Thu, Nov 29, 2012 at 05:27:32PM +0200, Muhammad Haggag <mhaggag at gmail.com> wrote:
> Sorry for the trouble. I build and test patches before pushing them. I
> did verify that this one built and ran, and that the help content is
> showing up correctly. I just double-checked on my development machine
> (where that change is the last committed to helpcontent2), and it
> still builds fine. So either the breakage was introduced during
> merging or afterwards.
> What was the build error you ran into?

No problem, different configurations can result in different problems, I
just wanted to make sure it at least worked for you. :-)

The problem was that at least here the paragraph ids in xhp files are
not optional, Stephan had the same problem.

For the reference, here is the error:

Entering /home/vmiklos/git/libreoffice/master-4git/helpcontent2/source/text/schart/02

Error: Duplicated entry. ID =   LANG = en-US in File /home/vmiklos/git/libreoffice/master-4git/helpcontent2/source/text/shared/guide/redlining_navigation.xhp
dmake:  Error code 255, while making '../../../../unxlngx6.pro/misc/text_shared_guide.done'

        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:

  internal build errors:

ERROR: error 65280 occurred while making /home/vmiklos/git/libreoffice/master-4git/helpcontent2/source/text/shared/guide

 it seems that the error is inside '', please re-run build
 inside this module to isolate the error and/or test your fix:

build_error.log should contain the captured output of the failed module(s)

To rebuild a specific module:

make .clean # optional

when the problem is isolated and fixed, re-run 'make'
make[1]: *** [helpcontent2] Error 1
make[1]: Leaving directory `/home/vmiklos/git/libreoffice/master-4git'
make: *** [helpcontent2] Error 2

05bd6789ba844772f9757fa1196175e9591ccd74 in help.git fixed it.

But I have no idea at the moment how it didn't cause a problem at you. ;-)


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://lists.freedesktop.org/archives/libreoffice/attachments/20121129/6deb081d/attachment-0001.pgp>

More information about the LibreOffice mailing list