[PUSHED] rtl::OUString to OUString and some questions
pmladek at suse.cz
Thu Oct 18 05:57:20 PDT 2012
On Sat, 2012-10-13 at 20:14 +0200, oger000 wrote:
> Preface: I am a novice in many things.
> To get familiar with the stringclasses I chose the "rtl namespace prefix
> removal" because I have seen some patches of this kind on the mailinglist.
> My questions:
> 1) I did not find background info - at least not at
> <https://wiki.documentfoundation.org/Development/String_Classes> why the
> removing of the "rtl::" namespace prefix is preferable.
> Any pointers? - or is it more a cosmetic cleanup?
I think that it is part of a bigger task where we want to use only one
string class if possible. Also we want to use it an easier way. For
example we could use OUString("bla") instead of
RTL_CONSTASCII_USTRINGPARAM("bla")). In some constructs, we could even
use "bla" directly in the assigment. Such code is easier to read and
maintain. I think that Lubos or Ricardo could tell you more details
Well, I remember that Michael wanted to postpone such trivial changes a
bit because he did a license check and it made it more complicated.
Instead, he suggested to look at the slightly more complicated changes
that you might find at http://wiki.documentfoundation.org/Easy_Hacks
If you want to work with strings, you might have a look at
> 2) A "make clean; make all" was successfull. Is this enough to think the change
Anyway, the change looked fine => I pushed it to master.
Last thing. I do not find you name at
http://wiki.documentfoundation.org/Development/Developers. Could you
please send a blank license statement to this mailing list? It would
allow us to integrate your further patches. For example, see
Thanks a lot for contribution.
PS: Please, be patient. Most developers are on the LibreOffice
conference this week, so we have worse response time than usual :-)
More information about the LibreOffice