[PATCH] revert back to usign autogen.sh cmdline arguments if given
Luboš Luňák (via_Code_Review)
gerrit at gerrit.libreoffice.org
Wed Apr 3 09:07:28 PDT 2013
Hi,
I have submitted a patch for review:
https://gerrit.libreoffice.org/3190
To pull it, you can do:
git pull ssh://gerrit.libreoffice.org:29418/core refs/changes/90/3190/1
revert back to usign autogen.sh cmdline arguments if given
This is a partial revert of ca0c54d0fe3812cec64e5c7cc83309d4397f5e0a .
Ignoring cmdline arguments if autogen.* exists is broken for several reasons:
- autogen.sh of every other package passes cmdline arguments to configure
- that's because if I was bothered to give them, I want them used
- there's no reason to prefer autogen.input now, given that autogen.input
cannot be overwritten by autogen.sh, unlike autogen.lastrun , so there's
no accidental loss of the switches
- running autogen.sh --foo followed by autogen.sh --bar actually runs
configure with --foo the second time too, because the first one creates
autogen.lastrun and the second one first complains about the cmdline
args, then complains about autogen.lastrun, and then uses it
Change-Id: I5868610935d0312915be74602b6435eea069f937
---
M autogen.sh
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/autogen.sh b/autogen.sh
index f5960e3..2498c5a 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -112,14 +112,14 @@
my $input = "autogen.input";
my $lastrun = "autogen.lastrun";
-if (-f $input) {
- warn "Ignoring command-line arguments, using $input.\n" if (@ARGV);
- warn "Ignoring $lastrun, using $input.\n" if (-f $lastrun);
- @cmdline_args = read_args ($input);
-} elsif (-f $lastrun) {
- warn "Ignoring command-line arguments, using $lastrun.\n" if (@ARGV);
- print STDERR "Reading $lastrun. Please rename it to $input to avoid this message.\n";
- @cmdline_args = read_args ($lastrun);
+if (!@ARGV) {
+ if (-f $input) {
+ warn "Ignoring $lastrun, using $input.\n" if (-f $lastrun);
+ @cmdline_args = read_args ($input);
+ } elsif (-f $lastrun) {
+ print STDERR "Reading $lastrun. Please rename it to $input to avoid this message.\n";
+ @cmdline_args = read_args ($lastrun);
+ }
} else {
@cmdline_args = @ARGV;
}
--
To view, visit https://gerrit.libreoffice.org/3190
To unsubscribe, visit https://gerrit.libreoffice.org/settings
Gerrit-MessageType: newchange
Gerrit-Change-Id: I5868610935d0312915be74602b6435eea069f937
Gerrit-PatchSet: 1
Gerrit-Project: core
Gerrit-Branch: master
Gerrit-Owner: Luboš Luňák <l.lunak at suse.cz>
More information about the LibreOffice
mailing list