Building LO on illumos based OS

Gabriele Bulfon gabriele.bulfon at
Mon Jul 1 05:58:58 PDT 2013

On Mon, Jul 1, 2013 at 6:39 AM, Gabriele Bulfon
gabriele.bulfon at
Hi, because I need to work on a consolidated tar.gz source version, I'm not
using master, so
I cannot pull changes at the moment.
Can you suggest me what modifications I need?
Ok, now I'm stuck again with not being resolved:
[build LNK] Executable/cppumaker
/usr/gnu/bin/ld: warning:, needed by /sources/userlands/xstream-userland-gate/components/libreoffice/libreoffice-, not found (try using -rpath or -rpath-link)
I tried using the commented options:
@@ -120,6 +120,7 @@
-L$(SYSBASE)/lib \
-L$(SYSBASE)/usr/lib \
-Wl,-z,combreloc \
+       -Wl,-rpath-link,$(SYSBASE)/lib:$(SYSBASE)/usr/lib \
but no luck, still cannot solve.
I also tried using Sun ld, but looks like options for ld are always gnu-ld ones, so compilation
stop much earlier.
...any clue?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the LibreOffice mailing list