Building LO on illumos based OS

Gabriele Bulfon gabriele.bulfon at
Mon Jul 1 08:20:58 PDT 2013

On 01/07/13 16:43, Michael Stahl wrote:
On 01/07/13 14:58, Gabriele Bulfon wrote:
[build LNK] Executable/cppumaker
/usr/gnu/bin/ld: warning:, needed by
not found (try using -rpath or -rpath-link)
I tried using the commented options:
@@ -120,6 +120,7 @@
-L$(SYSBASE)/lib \
-L$(SYSBASE)/usr/lib \
-Wl,-z,combreloc \
+ -Wl,-rpath-link,$(SYSBASE)/lib:$(SYSBASE)/usr/lib \
but no luck, still cannot solve.
did you try adding it to definition of gb_Library__get_rpath like it's
done in ? (perhaps just copy that)
ah sorry the relevant one is gb_Executable__get_rpath
I also tried using Sun ld, but looks like options for ld are always
gnu-ld ones, so compilation
stop much earlier.
...any clue?
sure, if you want to use Sun ld you need to change quite a few things in to use different options.
Great suggestions! Path to the solution ;) it went through :)
Following your suggestion I found had many more lines about rpath,
the ones you pointed, and they were almost all changed from into
something different.
I guess the one who tried to do was using Sun ld instead of Gnu.
It's going on building now......... ;)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the LibreOffice mailing list