junit autogen error?

Joseph Pellegrino jdpellegrino at comcast.net
Tue Nov 12 18:14:31 PST 2013

I am not sure if this is the right list to post this question if not please accept my apologies and let me know which is the appropriate list. I’ve also tried to find similar posts along this line but I didn’t find one. Anyhow, I recently checked out the current version of LO (git clone git://gerrit.libreoffice.org/core) and tried to run the build configuration (autogen.sh) and ultimately got the following error:

checking for JUnit 4... no
configure: error: cannot find JUnit 4 jar; please install one in the default
location (/usr/share/java), specify its pathname via
--with-junit=..., or disable it via --without-junit
Error running configure at ./autogen.sh line 209.

When I specify the junit path:

./autogen.sh --with-junit=/opt/local/share/java/

I get the same error. I’ve tried several versions of junit with different versions of hamcrest but can’t seem to get a successful configuration without excluding junit. I am wondering if anyone could give me a hint as to the issue.

Some additional information:

OS X v10.9
junit-4.11, hamcrest-core-1.3

$ automake --version
automake (GNU automake) 1.14

$ gcc -v

Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr --with-gxx-include-dir=/usr/include/c++/4.2.1
Apple LLVM version 5.0 (clang-500.2.79) (based on LLVM 3.3svn)
Target: x86_64-apple-darwin13.0.0
Thread model: posix

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/libreoffice/attachments/20131112/56157df7/attachment.html>

More information about the LibreOffice mailing list