Question about debugging cppunit tests

Markus Mohrhard markus.mohrhard at
Sun May 4 05:47:44 PDT 2014


On Sun, May 4, 2014 at 9:10 AM, julien2412 <serval2412 at> wrote:

> Hello,
> I'm trying to run gdb on cppunit failing by following this:
> to rerun just this failed test without all others, run:
>     make JunitTest_chart2_unoapi
> cd into the module dir to run the tests faster
> Or to do interactive debugging (non-Windows), run two shells with:
>     make debugrun
>     make gb_JunitTest_DEBUGRUN=T JunitTest_chart2_unoapi
> So I open 2 console shells.
> On first one, I run "make debugrun"
> On second one, I run "make gb_JunitTest_DEBUGRUN=T JunitTest_chart2_unoapi"

I suppose that you want to debug the failing RegressionCurve test. That one
has just been disabled again with ae1d664008edeb509829265e92ba778d00858d8a
and is tracked as fdo#66617. It requires some rework in the chart2 UNO API
to fix this regression.

> But first one just always displays this:
> Reading symbols from
> /home/julien/compile-libreoffice/libreoffice/instdir/program/soffice.bin...done.
> (gdb)
> and that's all.
> It must be obvious but I miss the point.
> seems
> outdated
> since it doesn't talk about this way. Moreover, I tried 'export
> CPPUNITTRACE="gdb --args"' and it does nothing when running then 'make
> JunitTest_chart2_unoapi' for example.

This is not a cppunit test. As the output after the test already tells you
it is a Junit test, so this can't work.

> Any idea?
> Julien
> --
> View this message in context:
> Sent from the Dev mailing list archive at
> _______________________________________________
> LibreOffice mailing list
> LibreOffice at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the LibreOffice mailing list