Configure fail on OS X 10.9 - Cannot create Makefile - Claims Ant too old and doesn't work

Husain husain.amri at
Thu May 15 20:58:17 PDT 2014

Dear all,

Greetings, I am a new contributor, I have prior experience in building projects on OS X and Linux, however I have been having issues with LibreOffice on OS X.

On OS X 10.9 (Mavericks) Apple doesn't include Apache Ant by default, so I installed Ant but when I ran I got the following error:

checking if /usr/local/Cellar/ant/1.9.4/libexec/bin/ant works...
configure: WARNING: Ant does not work - Some Java projects will not build!
checking whether Ant is >= 1.6.0... ./configure: line 39155: test: not /System/Library/Frameworks/JavaVM: integer expression expected
./configure: line 39158: test: framework/Versions/CurrentJDK/Home/bin/java: integer expression expected
configure: error: no, you need at least Ant >= 1.6.0
configure: error: no, you need at least Ant >= 1.6.0
Error running configure at ./ line 257.

I executed the following to confirm my java, javac and ant versions:

ant -version
Apache Ant(TM) version 1.9.4 compiled on April 29 2014

java -version
java version "1.8.0_05"
Java(TM) SE Runtime Environment (build 1.8.0_05-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.5-b02, mixed mode)

javac -version
javac 1.8.0_05

I have used ant, java and javac and they all work. I compiled and ran different java code samples and I ran ant -f fetch.xml -Ddest=system which returned successfully. 

There is a previous mailing list discussion regarding this same problem ( and no solution was provided.

-- Alamri Hussian
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the LibreOffice mailing list