MSVC 14.0 U3: LO msi package put VC redist libraries in wrong directory

David Ostrovsky d.ostrovsky at
Mon Aug 1 06:13:34 UTC 2016

So, one year later, and even with upgrade 3 of MSVC 14.0 installed, the
problem reported here still doesn't seem to be fixed: [1]. Or at least
it still doesn't work with LO msi tool chain. In my case, it was
installing the redist libraries in C:\System64 directory. Looking into
the merge module, it diverges in directory table from working msm
module from MSVC 12.0.

One approach to fix it is to patch the merge module (more or less
reproduce the situation with working msm package from MSVC 12.0). The
process is documented here: [2].

The question is if there is a better way to achieve what we want,
though, as to mess around with msm file supplied by the MSVC 14.0, e.g.
try to substitute somehow the variable in question in msi build:


I wonder if someone could give the LO msi built that way a try,
recent master, 64bit, release mode: [3]? LO should be installed on a
fresh Windows 64bit, installation, without and development tools and/or
any other applications that could supply vc_redist from MSVC 14.0 (i
wonder how it would work for them, though?) installed. Ideally, install
new Windows 64bit, install LO, try to start it.

As another test, before LO installation this file (and another 3):
shouldn't exist, after the installation it should be there.



More information about the LibreOffice mailing list