Error compiling "unknown external: glew. Stop."

Kirk Puppy kirkpuppy at
Tue Sep 27 01:01:22 UTC 2016

Right you are. I did have --enable-mpl-subset. I guess I should have posted
my configuration. Building right now.
Thanks for your help!

On Mon, Sep 26, 2016 at 3:11 PM, Michael Stahl <mstahl at> wrote:

> On 26.09.2016 18:23, Kirk Puppy wrote:
> > Hi all,
> >
> >       Tring to compile on linux. Keep getting
> > "libreoffice- /*/
> > gb_LinkTarget_use_external: unknown external: glew. Stop." This error
> > pops up in less than a minute after doing  "make build-nocheck".
> > After running make glew-1.12 was downloaded but not built.  I compiled
> > and installed libGlew-1.13 and then tried again with
> > "--with-system-glew" and I still get the same error. Any Ideas?
> the only thing that could explain that for both values of SYSTEM_GLEW is
> an empty ENABLE_OPENGL variable.
> are you by any chance using --enable-mpl-subset ? that seems to have a
> bug here.  i think testing only ENABLE_OPENGL may not be correct.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the LibreOffice mailing list