LibreOffice Core Development build Issue

Koushik Sekhar koushik.sekhar at
Tue Oct 24 23:39:45 UTC 2017

Thank you Michael for your suggestion. I was able to rectify that error 
by using the --enable-64-bit flag and also, configured the build 
successfully. Now, I am trying to build the right version of the make 
file to build and run libreOffice.

Thank you again!


Koushik Sekhar

by using the flag --enable-64-bit

On 10/24/2017 12:10 PM, Michael Stahl wrote:
> On 24.10.2017 20:37, Koushik Sekhar wrote:
>> I have installed Visual Studio 2015 update 3 on my system. I figured out
>> that VC++ was not installed so installed the same and ran a small
>> program to verified the same. Now, when I ran the \ file
>> again, I am getting error again.
> that's great, the error is not related to Visual Studio so that
> hopefully works now!
>> Below message shows the error:
>> configure: error: No JDK found, pass the --with-jdk-home option pointing
>> to a 32 bit JDK
>> Error running configure at /cygdrive/c/sources/libo-core/ line
>> 293.
>> I am using a 64-bit windows system and so I installed a 64-bit JDK. Is
>> it necessary that I install a 32-bit JDK now?  Also, could I use any
>> version for the JDK or is there any specific JDK version I should use?
> by default, a 32-bit LO will be built, which requires a 32-bit JDK.  but
> you can also build a 64-bit LO by using the flag --enable-64-bit, in
> which case your installed JDK should work fine.
> HTH,
>   michael

More information about the LibreOffice mailing list