dconf error during make

Aditya Sood sood.aditya.08 at gmail.com
Sat Mar 3 15:17:03 UTC 2018

I'm Aditya Sood. I've been trying to build the project (for Android) on my
system, so as to start with the easy hacks, but I've run into this problem
during the command *make *:

(I have followed the previous steps of installing dependencies specific to
the project on my Ubuntu system at: https://wiki.documentfoundation.org/

**/libreoffice/configmgr/source/dconf.cxx:23:10: fatal error:
'dconf/dconf.h' file not found*
*#include <dconf/dconf.h>*
*         ^~~~~~~~~~~~~~~*
*1 error generated.*
*/libreoffice/solenv/gbuild/LinkTarget.mk:291: recipe for target
'*/libreoffice/workdir/CxxObject/configmgr/source/dconf.o' failed
make[1]: *** [*/libreoffice/workdir/CxxObject/configmgr/source/dconf.o]
Error 1
make[1]: *** Waiting for unfinished jobs....
Makefile:280: recipe for target 'build' failed
make: *** [build] Error 2

This is followed by termination of the build.

*What I have done so far*:

*(1)* Checked the standard include paths. The dconf directory was present
with sub-directories & header files.

*(2)* Checked the line *libreoffice/configmgr/source/dconf.cxx:23:10*. It
contained the following:

*  20     extern "C" {*
*  21         // <https://bugzilla.gnome.org/show_bug.cgi?id=754245
*  22         // "common/dconf-changeset.h etc. lack extern "C" wrapper for
*  23        *#include <dconf/dconf.h>
*  24     *

I checked the link - The bug had been resolved in Jan '16 (Plus I set up my
current distro only this year, so all the more reason that my systems code
doesn't have the bug.)

*(3) *Tried *sudo make*
Got this error:

*No. You make ME a sandwich. *(Reference to the Batman-Superman sandwich

*Makefile:62: recipe for target 'check-if-root' failed*
*make: *** [check-if-root] Error 1*

*(4)* Tried compiling a file using the header file in question (with and
without *sudo*).

The code:

*int main()*
*    return 0;*

Failed to compile with the error:
*In file included from test.cpp:1:0:*
*/usr/include/dconf/dconf.h:23:10: fatal error: common/dconf-enums.h: No
such file or directory*
* #include <common/dconf-enums.h>*
*          ^~~~~~~~~~~~~~~~~~~~~~*
*compilation terminated.*

Key thing to notice here is that *there is* a file

*(5) *Googled this error of file not being found despite being present.
Followed this response: https://askubuntu.com/a/454452/784969, about how it
could be a 32-bit binary trying to be run on a 64-bit system without
*sudo dpkg --add-architecture i386*
*sudo apt-get update*
*sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386*

Now *Error 1 *is followed by a ton of warnings and notes, before giving *Error
2*. So it is same as before, but with all those additional warnings and

Any help is much appreciated

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/libreoffice/attachments/20180303/173c4ffd/attachment.html>

More information about the LibreOffice mailing list