Windows 10 process argument limit issue

Austin Stephens astephens at
Wed Jun 26 17:07:23 UTC 2019

On 6/26/2019 10:23 AM, Austin Stephens wrote:
> On 6/26/2019 9:48 AM, Austin Stephens wrote:
>> On 6/26/2019 9:22 AM, Michael Stahl wrote:
>>> maybe it's the top-level one that is problematic?
>>> so you must have "HAVE_GNUMAKE_FILE_FUNC=" in
>>> you could check and look what GNUMAKE it detects, if it's
>>> the expected one... and why the HAVE_GNUMAKE_FILE_FUNC check around line
>>> 5183 fails.
>> I can confirm that "HAVE_GNUMAKE_FILE_FUNC=" is in Running the test manually passes so it should set it to true. I am going to try running again. Maybe I didn't have LODE_HOME defined when I ran it last, so it used the wrong make?
> So, the output of gives me
>> checking the GNU Make version... D:/cygwin64/opt/lo/bin/make 4.0
>> checking whether GNU Make supports the 'file' function... no
> Oddly enough the make that cygwin comes with is the same version, built for "x86_64-unknown-cygwin" , so I don't think that is the issue. I am going to try running configure as "sh -x configure 2>log" and see what I get from that.
So, I have determined that it was a permissions issue. I tried to set my cygwin tmp dir up so it behaved like it was sticky like the unix /tmp. Apparently I set it up wrong and the Makefile for testing the file function had the permissions of ---xr-xr-x. I fixed it by ensuring "CREATOR OWNER" had all of the permissions. Thanks for the help!

Austin Stephens
Western Standard
Fluency Dev

More information about the LibreOffice mailing list