Parameter out of range (here we go again.)

Dan Lewis elderdanlewis at
Mon Mar 11 14:14:12 UTC 2019

I ran into a problem yesterday when my timezone in the US went from 
standard time to daylight savings time. The MySQL J/connector 8.0.15 has 
a bug that prevents a connection to the MySQL server with a modification 
of the database name. I solved this problem. But then when I opened a 
form with a subform, the data would not load with an explanation 
beginning with "Parameter index out of range...".  I filed this bug 
report: 123999.

I and others had a similar problem when opening a database that had been 
created before LibreOffice 6.2 but opened with version 6.2. The problem 
was "db parameter-name-substitution="false" in the context.xml file in 
the database file. So this had already been removed, and the form had 
worked properly the day before the time change.

I wondered if beginning with a new database on LibreOffice to 
connect to the MySQL server would work. It did not. In fact, when I 
edited the content.xml file, I located "db 
parameter-name-substitution="false" in it. (Is this a regression?)


More information about the LibreOffice mailing list