Error in building

Mike Kaganski mikekaganski at
Sun Jul 5 14:38:14 UTC 2020

On 05.07.2020 17:30, anshu khare wrote:
> Could you please tell me the exact command?

The command was already mentioned by Julien

Specifically, you wrote this:

> On running make clean, the output is :
> rm -fr C:/build/test-install
> make: rm: No such file or directory
> make: *** [Makefile:177: clean-host] Error 127

... after which you wrote:

> I tried to build it.. But it's giving the same error

> To be specific the error when i run
>  /opt/lo/bin/make gb_COLOR=1
> is
> C:/sources/libo-core/sal/osl/all/debugbase.cxx: fatal error C1853:
> 'C:/build/workdir/PrecompiledHeader/nodebug/precompiled_sal.hxx.pch'
> precompiled header file is from a different version of t
> he compiler, or the precompiled header is C++ and you are using it from C
> (or vice versa)

The problem seemed to be using `make clean` literally, not turning
`make` into `/opt/lo/bin/make` to clean. Since that call failed to find
`rm`, it naturally hadn't removed nothing, and you re-tried to build in
the unchanged working tree.

Best regards,
Mike Kaganski
-------------- next part --------------
A non-text attachment was scrubbed...
Name: pEpkey.asc
Type: application/pgp-keys
Size: 1769 bytes
Desc: not available
URL: <>

More information about the LibreOffice mailing list