Problem with vswhere.exe

Ilmari Lauhakangas ilmari.lauhakangas at
Fri Dec 3 11:09:45 UTC 2021

On 24.11.2021 15.09, Ilmari Lauhakangas wrote:
> It seems there is some recent issue with vswhere.exe that is making the 
> invocation in our give blank output. This is now affecting 
> three newcomers.
> Mike Kaganski has been providing assistance and we have double-checked 
> screenshots of Visual Studio installer. The installers show the right 
> components, but this command outputs nothing on the affected systems:
> "C:\Program Files (x86)\Microsoft Visual Studio\Installer\vswhere.exe" 
> -prerelease -version "[ 16 , 17 )" -requires 
> Microsoft.VisualStudio.Component.VC.Tools.x86.x64 -property 
> installationPath
> This happened both with VS2019 and 2022.
> Any ideas on how to troubleshoot this?

One of these was now solved in a screensharing call with Hossein. The 
reson was that with VS2022 one needs this in autogen.input:


The VS2019 one was solved earlier with a Windows update.

The third person was also using VS2022, so I will let them know about this.


More information about the LibreOffice mailing list