[SOLVED] Re: Error when building on Windows 10 with LODE

julien2412 serval2412 at yahoo.fr
Sat May 1 16:22:15 UTC 2021


Thanks to
"author	Christian Lohmaier <lohmaier+LibreOffice at googlemail.com>	2021-05-01
10:40:58 +0200
committer	Christian Lohmaier <lohmaier+LibreOffice at googlemail.com>
2021-05-01 15:07:31 +0200
commit	07f1ec0af02a9ab6c1bf6e6478092ee50495afa7 (patch)
tree	9f075279dced945e872e0fbf4f3d727bee10e0c3
parent	afad6ba0f841985ee87a0a0871e10cda5d8913cc (diff)
avoid windres preprocessor quoting-messups with current cygwin
apparently fresh installs of cygwin behave differently with the windres
command's quoting and treats --preprocessor='cpp foo bar' as a single file
"cpp foo bar" to run instead of running "cpp" with the arguments "foo"
and "bar".
(-D and -I options are passed to the preprocessor automatically, so no
need to prefix those with --preprocessor-arg)
the problem is now solved, it's building right now.
Hope there won't be other problems.
Thank you Christian!


Sent from: http://document-foundation-mail-archive.969070.n3.nabble.com/Dev-f1639786.html

More information about the LibreOffice mailing list