Compiling LO for lcov/gcov code coverage fails (gb_GCOV=YES)

Luboš Luňák l.lunak at
Wed May 11 19:34:45 UTC 2022

On Wednesday 11 of May 2022, Maarten Hoes wrote:
> Thanks.
> I just noticed: reading back the error more carefully, I noticed it's clang
> that generated the error, even though I didn't specifically tried to
> compile with clang. (I had both clang and gcc installed). I uninstalled
> clang and only left gcc to see if that made any difference, and I still had
> a similar build error (although at another point in the build: 'skia' seems
> to build now). Error details listed below.
> The build now fails at building 'liborcus', and using 'verbose=t' shows the
> flags are indeed missing from the commandline. I tried adding the flags to
> 'core/workdir/UnpackedTarball/liborcus/src/Makefile' because they were not
> there, and then running 'make -C external Module_liborcus', but the
> modifications are lost/overwritten during the build (presumably because
> './configure' is run again, re-generating the Makefile ?).

 Not those makefiles. I meant external/*/*.mk (and solenv/gbuild/*.mk).

 Luboš Luňák
 l.lunak at

More information about the LibreOffice mailing list