[Libva] [PATCH 0/3] Split DRM/DRI states
Gwenole Beauchesne
gb.devel at gmail.com
Mon Jul 16 00:39:54 PDT 2012
Hi,
This patch series desribes backends explicitly and simplifies DRI
structs to a common base. This is a prelude to VA/DRM and VA/Wayland
APIs.
* Changes (v3):
- Some minor documentation fixes ;
- Document VADriverContext.drm_state purpose.
* Changes (v2):
- Use unsigned long for display_type ;
- Use new enums for VA_DRM_AUTH_* values.
Benjamin Franzke (1):
API: introduce DRM common utilities and data structures.
Gwenole Beauchesne (2):
API: backend: rename VADriverContext.dri_state to drm_state.
API: backend: add VA display types.
va/Makefile.am | 1 +
va/android/va_android.cpp | 25 ++++++++++++-----------
va/glx/va_glx.c | 1 +
va/va_backend.h | 35 ++++++++++++++++++++++++++++---
va/va_drmcommon.h | 50 +++++++++++++++++++++++++++++++++++++++++++++
va/x11/dri1_util.c | 28 ++++++++++++-------------
va/x11/dri2_util.c | 28 ++++++++++++-------------
va/x11/va_dricommon.c | 10 ++++-----
va/x11/va_dricommon.h | 16 +++++++--------
va/x11/va_x11.c | 7 ++++---
10 files changed, 142 insertions(+), 59 deletions(-)
create mode 100644 va/va_drmcommon.h
--
1.7.9.5
More information about the Libva
mailing list