[Libva] [Libva-intel-driver][PATCH v2 08/17] Rename i965_gpe_dri_object_to_2d_gpe_resource() to i965_dri_object_to_2d_gpe_resource()

Zhao Yakui yakui.zhao at intel.com
Fri Nov 18 06:29:45 UTC 2016


On 11/18/2016 01:43 PM, Xiang, Haihao wrote:
> Like as i965_dri_object_to_buffer_gpe_resource(), use i965_ instead of i965_gpe_ as prefix
>

This looks good to me.

Thanks

> Signed-off-by: Xiang, Haihao<haihao.xiang at intel.com>
> ---
>   src/gen9_post_processing.c |  2 +-
>   src/gen9_vp9_encoder.c     |  2 +-
>   src/i965_gpe_utils.c       | 10 +++++-----
>   src/i965_gpe_utils.h       | 10 +++++-----
>   4 files changed, 12 insertions(+), 12 deletions(-)
>
> diff --git a/src/gen9_post_processing.c b/src/gen9_post_processing.c
> index 862a26a..2128697 100644
> --- a/src/gen9_post_processing.c
> +++ b/src/gen9_post_processing.c
> @@ -578,7 +578,7 @@ gen9_add_dri_buffer_2d_gpe_surface(VADriverContextP ctx,
>       struct i965_gpe_resource gpe_resource;
>       struct i965_gpe_surface gpe_surface;
>
> -    i965_gpe_dri_object_to_2d_gpe_resource(&gpe_resource, bo, width, height, pitch);
> +    i965_dri_object_to_2d_gpe_resource(&gpe_resource, bo, width, height, pitch);
>       memset(&gpe_surface, 0, sizeof(gpe_surface));
>       gpe_surface.gpe_resource =&gpe_resource;
>       gpe_surface.is_2d_surface = 1;
> diff --git a/src/gen9_vp9_encoder.c b/src/gen9_vp9_encoder.c
> index a933c15..0b66565 100644
> --- a/src/gen9_vp9_encoder.c
> +++ b/src/gen9_vp9_encoder.c
> @@ -1052,7 +1052,7 @@ gen9_add_dri_buffer_2d_gpe_surface(VADriverContextP ctx,
>   {
>       struct i965_gpe_resource gpe_resource;
>
> -    i965_gpe_dri_object_to_2d_gpe_resource(&gpe_resource, bo, width, height, pitch);
> +    i965_dri_object_to_2d_gpe_resource(&gpe_resource, bo, width, height, pitch);
>       gen9_add_buffer_2d_gpe_surface(ctx,
>                                      gpe_context,
>                                      &gpe_resource,
> diff --git a/src/i965_gpe_utils.c b/src/i965_gpe_utils.c
> index 66609c0..b20857b 100644
> --- a/src/i965_gpe_utils.c
> +++ b/src/i965_gpe_utils.c
> @@ -1413,11 +1413,11 @@ i965_dri_object_to_buffer_gpe_resource(struct i965_gpe_resource *res,
>   }
>
>   void
> -i965_gpe_dri_object_to_2d_gpe_resource(struct i965_gpe_resource *res,
> -                                       dri_bo *bo,
> -                                       unsigned int width,
> -                                       unsigned int height,
> -                                       unsigned int pitch)
> +i965_dri_object_to_2d_gpe_resource(struct i965_gpe_resource *res,
> +                                   dri_bo *bo,
> +                                   unsigned int width,
> +                                   unsigned int height,
> +                                   unsigned int pitch)
>   {
>       unsigned int swizzle;
>
> diff --git a/src/i965_gpe_utils.h b/src/i965_gpe_utils.h
> index 66be748..22165da 100644
> --- a/src/i965_gpe_utils.h
> +++ b/src/i965_gpe_utils.h
> @@ -348,11 +348,11 @@ void i965_object_surface_to_2d_gpe_resource(struct i965_gpe_resource *res,
>   void i965_dri_object_to_buffer_gpe_resource(struct i965_gpe_resource *res,
>                                               dri_bo *bo);
>
> -void i965_gpe_dri_object_to_2d_gpe_resource(struct i965_gpe_resource *res,
> -                                            dri_bo *bo,
> -                                            unsigned int width,
> -                                            unsigned int height,
> -                                            unsigned int pitch);
> +void i965_dri_object_to_2d_gpe_resource(struct i965_gpe_resource *res,
> +                                        dri_bo *bo,
> +                                        unsigned int width,
> +                                        unsigned int height,
> +                                        unsigned int pitch);
>
>   void i965_zero_gpe_resource(struct i965_gpe_resource *res);
>



More information about the Libva mailing list