Mesa (master): glapi: rename/ move GL_POLYGON_OFFSET_BIAS to its extension section

Oliver McFadden omcfadde at kemper.freedesktop.org
Wed Oct 10 09:45:14 UTC 2012


Module: Mesa
Branch: master
Commit: 7182a1fc5ea49dffb7678f6248d5c13a003aca62
URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=7182a1fc5ea49dffb7678f6248d5c13a003aca62

Author: Imre Deak <imre.deak at intel.com>
Date:   Mon Sep 10 08:46:07 2012 +0300

glapi: rename/move GL_POLYGON_OFFSET_BIAS to its extension section

This should be named GL_POLYGON_OFFSET_BIAS_EXT and listed under the
EXT_polygon_offset section. (Solution by Ian Romanick)

Signed-off-by: Imre Deak <imre.deak at intel.com>
Reviewed-by: Brian Paul <brianp at vmware.com>
Reviewed-by: Oliver McFadden <oliver.mcfadden at linux.intel.com>

---

 src/mapi/glapi/gen/gl_API.xml |    3 ++-
 1 files changed, 2 insertions(+), 1 deletions(-)

diff --git a/src/mapi/glapi/gen/gl_API.xml b/src/mapi/glapi/gen/gl_API.xml
index 751a18f..f83a7a7 100644
--- a/src/mapi/glapi/gen/gl_API.xml
+++ b/src/mapi/glapi/gen/gl_API.xml
@@ -2981,7 +2981,6 @@
     <enum name="POLYGON_OFFSET_FACTOR"         count="1"  value="0x8038">
         <size name="Get" mode="get"/>
     </enum>
-    <enum name="POLYGON_OFFSET_BIAS"                      value="0x8039"/>
     <enum name="ALPHA4"                                   value="0x803B"/>
     <enum name="ALPHA8"                                   value="0x803C"/>
     <enum name="ALPHA12"                                  value="0x803D"/>
@@ -8089,6 +8088,8 @@
 </category>
 
 <category name="GL_EXT_polygon_offset" number="3">
+    <enum name="POLYGON_OFFSET_BIAS_EXT"                  value="0x8039"/>
+
     <function name="PolygonOffsetEXT" offset="assign">
         <param name="factor" type="GLfloat"/>
         <param name="bias" type="GLfloat"/>




More information about the mesa-commit mailing list