Mesa (master): 29 new commits

Kenneth Graunke kwg at kemper.freedesktop.org
Sun Oct 13 07:11:57 UTC 2013


URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=8958741e5a0c3cce95f0415ce8e6e8e840a5207d
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Fri Sep 27 16:11:36 2013 -0700

    i965: Merge intel_context.h into brw_context.h.
    
    v2: Keep the random 32-bit only version of memcpy, since Ian says I
        can't delete it without data proving it isn't useful.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=3dda3ebec91ab9dfae8e9b9314d243cd86921ae0
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Fri Sep 27 15:32:20 2013 -0700

    i965: Delete our copy of likely/unlikely macros.
    
    brw_context.h includes imports.h which includes compiler.h which already
    defines these.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=67601da24c98a13a1a349b4e3df38ad10ff812bb
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Sun Jul 7 18:44:12 2013 -0700

    mesa: Move U_FIXED/S_FIXED macros from i965 to macros.h.
    
    These make it easy to convert a floating point value to a fixed point
    numbers.  The second parameter is the number of bits used for the
    fractional part of the number.
    
    It looks like core Mesa has similar functions already, but none that
    allows an arbitrary number of fractional bits.  The more generic version
    is probably useful to everyone.
    
    r600g apparently has an identical copy of the S_FIXED macro, but doesn't
    include this file.  I'm not sure what to do about that, so I'm just
    going to leave it for now.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=1a82081db6e57eaa74f852ed8acb391a7f4c2ca6
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Sun Jul 7 18:38:38 2013 -0700

    mesa: Move ROUND_DOWN_TO() macro from i915/i965 to macros.h.
    
    This seems generally useful, so it may as well live in core Mesa.
    
    In fact, the comment for ALIGN() in macros.h actually says to "see also"
    ROUND_DOWN_TO, which...was in a driver somewhere.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=50c9f04c5f5700ac27f8552694d2a2f2ab6fe89f
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Fri Sep 27 15:29:00 2013 -0700

    i965: Move need_workaround_flush = true to intel_batchbuffer_init.
    
    intel_batchbuffer_init() sets up initial batchbuffer state; it seems
    like a reasonable place to initialize this flag.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=ddc8decdb211f905bad5c903a38cd3cbbf62418d
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Fri Sep 27 15:00:22 2013 -0700

    i965: Move DriverFlag initialization to brw_init_state().
    
    Configuring which dirty flags we want sounds like a job for
    brw_init_state().
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=ba0cc79ab936fb0a5c7a666b98f69c28b31a00b5
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Fri Sep 27 14:57:47 2013 -0700

    i965: Merge intelInitContext into brwCreateContext.
    
    The split here was completely arbitrary.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=90d52d2c76f88f1b3999ebbc7f737800e4b9bd06
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Fri Sep 27 14:52:06 2013 -0700

    i965: Move viewport driver hook setup to brw_init_driver_functions.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=f118fc26e14b460e1dfb735892b1627948f592fc
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Fri Sep 27 14:46:26 2013 -0700

    i965: Make brwInitFunctions take brw_context rather than intel_screen.
    
    It actually just wants generation checking, and brw->gen is the usual
    way of doing that.  In the future, we'll also want to check brw->hw_ctx,
    which isn't available from the screen.
    
    While we're changing the function signature, convert from camel case to
    our usual naming conventions.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=9848a422879e0b5fef5930bfcb105b01d94f3bab
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Fri Sep 27 14:42:43 2013 -0700

    i965: Merge intelInitFunctions() and brwInitFunctions().
    
    They do exactly the same thing.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=0138fd46104850afe2e86483f3d3a436007b2c12
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Fri Sep 27 14:36:49 2013 -0700

    i965: Merge intel_context.c into brw_context.c.
    
    There's no point in having two files for context functions.  This patch
    moves the code from intel_context.c into brw_context.c unmodified
    (other than whitespace fixes).
    
    Right now, this looks silly; future patches will merge functions and
    tidy things up.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=8d315b25830de88108a87b2d555d54f7691e7983
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Fri Sep 27 11:34:09 2013 -0700

    i965: Move memset of TextureFormatSupported to brw_init_surface_formats.
    
    brw_init_surface_formats already sets entries in TextureFormatsSupported
    to true; it may as well take care of initializing it to false too.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=fc5b865cec99c34586b2f5484c46af419b2a0395
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Thu Sep 26 12:10:48 2013 -0700

    i965: Remove has_aa_line_parameters.
    
    This flag is only used in one place, and is only set on one platform.
    Just check for original Gen4 in the relevant function.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=220c1e5610faf228e342153e544a3ce9040301a1
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Thu Sep 26 12:06:32 2013 -0700

    i965: Move state setup from brwCreateContext to brw_init_state().
    
    This seems like a better place for it, and helps clean up
    brwCreateContext (which is full of a lot of random stuff).
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=d31b928b93694de0a1408f36acb675485fea5973
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Thu Sep 26 12:03:41 2013 -0700

    i965: Remove the brw_context::emit_state_always flag.
    
    This was always set to false, and is only used for debugging.
    To enable it, simply change the if (0) block and recompile.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=02b632d8e8f2b14c155740d28c276b5869305c60
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Thu Sep 26 11:55:36 2013 -0700

    i965: Move hardware feature flags to brw_device_info.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=ea890c031ddc69abb6670ad9b769ef1eecd11e28
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Thu Sep 26 11:36:42 2013 -0700

    i965: Move device quirks to brw_device_info.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=d76f6c7ae4d738193af2b3a06c4e6321e5e4daac
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Wed Sep 25 17:01:55 2013 -0700

    i965: Move hardware limits to brw_device_info.
    
    Since each kind of device has its own brw_device_info structure, we can
    simply store the URB and thread limits there.  This eliminates all the
    large if-ladders, and simplifies the context initialization code quite a
    bit.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=afe05e71931f53843999ea967946fae1b219a374
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Thu Jul 4 12:35:22 2013 -0700

    i965: Replace some intel_screen fields with brw_device_info references.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=9d490c172b023e9454714ca7f773996a0261e56a
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Thu Jul 4 12:28:59 2013 -0700

    i965: Delete the INTEL_SEPARATE_STENCIL override.
    
    This option was useful during initial development, but it's been ages
    since I've heard of anyone using it.  Plus, Gen7+ mandates separate
    stencil, so it was really only useful on Sandybridge anyway.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=6e9f427ed8a20d78e7d832b163d757827dd3e74f
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Thu Jul 4 12:11:36 2013 -0700

    i965: Add a new brw_device_info structure.
    
    The idea is that struct brw_device_info should store statically-known
    information about hardware features.  Using the new family name in the
    PCI ID table, we can easily grab the right structure.
    
    This is basically the equivalent of intel_device_info in the kernel.
    
    This patch also makes the new structure available from intel_screen, but
    nothing uses it.  Right now, it looks very redundant with existing
    fields, but that will change.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=4a29b9a066737398890755ed9987e49841aac60f
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Thu Jul 4 12:02:41 2013 -0700

    i965: Add the family name to the PCI ID table.
    
    I removed this a while ago, since we never used it, but I'm finally
    resurrecting the idea in the next commits.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=8d4ecbccd6a5608005b5c8f473d9a44dbde0b08d
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Thu Jul 4 11:55:36 2013 -0700

    i965: Remove #define name from PCI ID table.
    
    Nothing uses the #define name, and it's not terribly useful - the
    numerical ID serves the same purpose.  The only thing we could really do
    with it is generate slightly prettier preprocessed code.  But who looks
    at that?
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=90511faedddff834ab1f6d92f4d5d25a3c32bd82
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Fri Sep 27 10:40:57 2013 -0700

    i965: Pull most driconf option handling into a centralized function.
    
    Using a helper function clarifies the context initialization code.
    
    I would've liked to completely centralize it, but moving the optionCache
    code from intelInitExtensions into here would've required setting flags
    in the context, which seems like a waste.
    
    v2: Rebase for the introduction of disable_derivative_optimization.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=0fb525b87ceae543d581a5755ca547b54c58aa76
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Wed Sep 25 15:57:08 2013 -0700

    i965: Move a bunch of code from intelInitContext to brwCreateContext.
    
    Now that intelInitContext isn't shared between i915 and i965, the split
    is fairly arbitrary.  This patch moves a bunch of the basic context
    creation and generation checking code up to the top-level function
    (and slightly earlier).
    
    More will follow.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=a25caad9e4ed848e8b1169376901d6b9889faa80
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Fri Sep 27 10:13:55 2013 -0700

    i965: Update the comment about viewport hacks.
    
    It wasn't clear that this was necessary for EGL, or why.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=832bcc36133107e604a89f1762b9794fa7fc52ca
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Sun Jul 7 19:02:56 2013 -0700

    i965: Pull out INTEL_DEBUG handling into new intel_debug.[ch] files.
    
    Now that there isn't an intel_context structure, the split between
    brw_context.[ch] and intel_context.[ch] is rather awkward and arbitrary.
    Removing intel_context.[ch] seems desirable, but not everything really
    belongs in brw_context.[ch], either.
    
    Moving INTEL_DEBUG handling into separate intel_debug.[ch] files should
    make them relatively easy to find.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=3f7b4e5d04cf9f0274ddcd37d573eb96f835278e
Author: Kenneth Graunke <kenneth at whitecape.org>
Date:   Wed Sep 25 15:48:41 2013 -0700

    i965: Rename brwCreateContext's error parameter to dri_ctx_error.
    
    "error" is a very generic name.  dri_ctx_error is the name used in
    intelInitContext(), which is more specific.
    
    Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
    Reviewed-by: Ian Romanick <ian.d.romanick at intel.com>

URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=95bd8a332d1c3f868d8e4ff454fb308acd9beed9
Author: Eric Anholt <eric at anholt.net>
Date:   Thu Sep 26 17:17:06 2013 -0700

    dri: Move i965-specific context flag logic to dri common.
    
    Nobody else yet can do a forward context anyway, but others should be able
    to do debug contexts, and those would have just had no effect currently.




More information about the mesa-commit mailing list