Mesa (master): zink: add VK_KHR_driver_properties

GitLab Mirror gitlab-mirror at kemper.freedesktop.org
Wed Jan 20 16:38:13 UTC 2021


Module: Mesa
Branch: master
Commit: 356a381600cb45d068492015061184457de78e63
URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=356a381600cb45d068492015061184457de78e63

Author: Mike Blumenkrantz <michael.blumenkrantz at gmail.com>
Date:   Wed Jan 20 09:24:43 2021 -0500

zink: add VK_KHR_driver_properties

yet another extension that breaks naming conventions for structs/enums,
even if it does so in a very sensible way

Reviewed-by: Bas Nieuwenhuizen <bas at basnieuwenhuizen.nl>
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/8284>

---

 src/gallium/drivers/zink/zink_device_info.py | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/src/gallium/drivers/zink/zink_device_info.py b/src/gallium/drivers/zink/zink_device_info.py
index 21ea498dde6..60bcfdc2eee 100644
--- a/src/gallium/drivers/zink/zink_device_info.py
+++ b/src/gallium/drivers/zink/zink_device_info.py
@@ -64,6 +64,9 @@ EXTENSIONS = [
     Extension("VK_KHR_external_memory"),
     Extension("VK_KHR_external_memory_fd"),
     Extension("VK_KHR_vulkan_memory_model"),
+    Extension("VK_KHR_driver_properties",
+        alias="driver",
+        properties=True),
     Extension("VK_EXT_conditional_rendering",
         alias="cond_render", 
         features=True, 
@@ -134,7 +137,9 @@ VERSIONS = [
 # There exists some inconsistencies regarding the enum constants, fix them.
 # This is basically generated_code.replace(key, value).
 REPLACEMENTS = {
-    "ROBUSTNESS2": "ROBUSTNESS_2"
+    "ROBUSTNESS2": "ROBUSTNESS_2",
+    "PropertiesProperties": "Properties",
+    "PROPERTIES_PROPERTIES": "PROPERTIES",
 }
 
 



More information about the mesa-commit mailing list