[Mesa-dev] [Bug 29404] New: "Cannot yet select" LLVM error with r300g, softpipe and llvmpipe

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Thu Aug 5 00:43:11 PDT 2010


           Summary: "Cannot yet select" LLVM error with r300g, softpipe
                    and llvmpipe
           Product: Mesa
           Version: git
          Platform: x86-64 (AMD64)
        OS/Version: Linux (All)
            Status: NEW
          Severity: normal
          Priority: medium
         Component: Other
        AssignedTo: mesa-dev at lists.freedesktop.org
        ReportedBy: steckdenis at yahoo.fr

Created an attachment (id=37581)
 --> (https://bugs.freedesktop.org/attachment.cgi?id=37581)
LLVM's SelectionDAG when trying to run Neverball with r300g


I use mesa git (commit "glx: Move deref after NULL check", Wed Aug 4 12:50:36
2010 -0400) and LLVM svn 110215.

When I try to test the r300g driver, or the llvmpipe one, a "Cannot yet select"
error message is output to the console by LLVM. It happens when I run glxgears
or any other 3D program (extreme tux racer, neverball, super tux kart). I
attached the complete output of the LLVM error when I run neverball, because
the output is way larger with the others.

The first line is always the same : it's always a "f32 = add f32 f32" pattern
that causes this bug.

I use an AMD Athlon 64 L110 (1,2Ghz, single core, mobile) with the MMX, 3DNOW,
SSE and SSE2 instruction sets. I also attached the contents of /proc/cpuinfo to
this bug. My graphics card is an ATI Radeon X1270 (RS690m, with 256MB of shared
memory, and 128MB of sideport memory).

lspci of the card : 01:05.0 VGA compatible controller: ATI Technologies Inc
RS690M [Radeon X1200 Series]

Uname -a : Linux my-laptop 2.6.35 #11 SMP PREEMPT Wed Aug 4 11:47:54 CEST 2010
x86_64 AMD Athlon(tm) Processor L110 AuthenticAMD GNU/Linux. I run this kernel
with ArchLinux, Xorg Server, libdrm git and mesa git.

I also reported this bug in the LLVM bugtracker :
http://llvm.org/bugs/show_bug.cgi?id=7813 .

I add that I was never able to use any LLVM-based Gallium rendering with this
computer I bought four months ago. It worked fine before on my other computer :
an AMD Athlon 64 X2 4000+ (2,4Ghz, MMX, 3DNOW, SSE, SSE2 (same instruction sets
as the ones I have now)) and an ATI Radeon X1250 (RS690, 128MB shared memory,
no sideport).

Btw, is it possible to ask Draw or any other Gallium module to output its LLVM
assembly (in the source form, if possible) before trying to assemble it ? It
will greatly help the LLVM devs to have a test for this bug.


Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the mesa-dev mailing list