[Mesa-dev] [Bug 29407] llvm 2.8 asserts: "Tried to create an integer operation on a non-integer type!"

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sun Aug 8 07:44:55 PDT 2010


--- Comment #14 from steckdenis at yahoo.fr 2010-08-08 07:44:55 PDT ---
Created an attachment (id=37702)
 --> (https://bugs.freedesktop.org/attachment.cgi?id=37702)
Use fneg instead of neg when inverting the sign of floats


I have very good news for you !

I recompiled my LLVM with all of its debug capabilities and asserts, and I ran
Neverball on it. I used GDB to catch the precise moment when a wrong
instruction is emitted, and I fixed the problem.

The fact is that more instructions than add, sub, mul and div need their float
counterpart. My patch fixes two "neg" instructions in lp_bld_tgsi_soa.c. It was
the fix I needed to be able to run Neverball. I will now see if there are more
places where an instruction needs to be replaced with its float counterpart,
but I need to find GL programs that use them. Maybe piglit can help me.

The second good news is that Neverball runs really fine with LLVM. I have an
AMD Athlon 64 X2 processor at 1,2Ghz, and Neverball ran at nearly 5 fps
(800x600), with its graphics settings set to the maximum. My processor was also
busy rendering a really big 3D scene, so only the half of the processing power
was available to llvmpipe. They weren't any glitches on the screen, even the
beautiful reflections of Neverball worked perfectly.

Thanks for all :) .

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the mesa-dev mailing list