[Mesa-dev] [Bug 29832] New: regarding the execution of Mesa demo programs.. plz help me....

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Fri Aug 27 02:21:20 PDT 2010


           Summary: regarding the execution of Mesa demo programs.. plz
                    help me....
           Product: Mesa
           Version: unspecified
          Platform: All
        OS/Version: Linux (All)
            Status: NEW
          Severity: blocker
          Priority: medium
         Component: GLUT
        AssignedTo: mesa-dev at lists.freedesktop.org
        ReportedBy: suma_s27 at yahoo.co.in

gud afternoon sir,

        I am new to directfb. i have installed directfb1.4.0 and able to run
successfully directfb demo examples. if i run dfbdump i get the following
root at lxdevenv:~/suma/Mesa-7.8.1/progs/demos# dfbdump

   ~~~~~~~~~~~~~~~~~~~~~~~~~~| DirectFB 1.4.0 |~~~~~~~~~~~~~~~~~~~~~~~~~~
        (c) 2001-2009  The world wide DirectFB Open Source Community
        (c) 2000-2004  Convergence (integrated media) GmbH

(*) DirectFB/Core: Multi Application Core. (2010-08-23 04:09) 
(*) Fusion/SHM: Using MADV_REMOVE ( >=
(*) Direct/Thread: Started 'Fusion Dispatch' (8059) [MESSAGING OTHER/OTHER 0/0]
(*) Direct/Thread: Started 'Virtual Input' (-1) [INPUT OTHER/OTHER 0/0]
(*) DirectFB/Input: Virtual Input 0.4 (Convergence GmbH)
(*) Direct/Thread: Started 'X11 Input' (-1) [INPUT OTHER/OTHER 0/0]
(*) DirectFB/Input: X11 Input 0.1 (directfb.org)
(*) DirectFB/Genefx: MMX detected and enabled
(*) DirectFB/Graphics: MMX Software Rasterizer 0.6 (directfb.org)
(*) DirectFB/Core/WM: SaWMan 0.2 (directfb.org)
(*) SaWMan: Initializing stack 0x20127900 for tier 0x25583000, 0x0, layer 0,
context 0x20017000 [3]...
(*) SaWMan/Init: Layer  0:  320x240, ARGB, options: 0
(*) SaWMan/Init: Border 0:  320x240, ARGB, options: 8

DirectFB uptime: 00:00:00

-----------------------------[ Surfaces ]-------------------------------------
Reference   FID  . Refs  Width Height  Format     Video   System  Capabilities
0x00000005 [  1] :   2    320 x  240       ARGB     0k       0k   video only   
                                                ------   ------
                                                    0k       0k   -> 0k total

----------------------------------[ Contexts of Layer 0
Reference   FID  . Refs  Width Height Format   Location on screen  Regions 
Active  Info    Level
0x00000003 [  1] :   3    320 x  240  ARGB     0.0, 0.0 -> 1.0, 1.0    1    
(*)    SHARED   N/A
 (!!!)  *** WARNING [still objects in 'Layer Region Pool'] *** [object.c:241 in
 (!!!)  *** WARNING [still objects in 'Layer Context Pool'] *** [object.c:241
in fusion_object_pool_destroy()]
 (!!!)  *** WARNING [still objects in 'Surface Pool'] *** [object.c:241 in


i wanted mesa to be running on top of directfb.so i  then installed
MesaLib-7.8.1, MesaGlut-7.8.1 and MesaDemo-7.8.1 by configuring and building it
as below. basically i wanted to builb mesa for dri drivers and i followed the
standard compiling and installation instructions provided in Mesa website.

./configure --prefix=/usr/project --enable-shared
make linux-dri
make install

iam successful through these steps. but while running demo programs iam facing
the following error:
root at lxdevenv:~/suma/Mesa-7.8.1/progs/demos# ./gears
GLUT: Fatal Error in gears: visual with necessary capabilities not found.

i did export the LIBGL_DRIVERS_PATH. the lib/ contains all the .so files
including mga_dri.so.

when i run any of the demo programs i get the same error.
so can u plz tell me where does the problem lies.?
is there any problem in the installation because of which iam facing this

i have installed Mesa with all its pre-reqiusites as mentioned in the
installation guide like
dri2proto, libdrm, xorg-server with the suitable versions.
currently iam building all these on vmware player with the kernel version
I just wanted to know, is this the error which is causing me the problem, since
mesa demands the kernel version of 2.6.28 as a pre-requisite.

plz help me in tracing this problem.. iam buged here only since from many

thanks in advance


Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the mesa-dev mailing list