[Mesa-dev] Build failure since May 6

Kevin H. Hobbs hobbsk at ohiou.edu
Mon May 10 12:25:04 PDT 2010

On 05/10/2010 02:13 PM, Dan Nicholson wrote:
> On Mon, May 10, 2010 at 10:08 AM, Kevin H. Hobbs <hobbsk at ohiou.edu> wrote:
>> All I really want is Mesa with OSMesa from the development repository as
>> the "reference" library for my VTK and ParaView nightly test builds.
> ./configure --with-driver=xlib ? That will link libOSMesa to libGL,
> but that's what configs/linux-x86-64 is already doing (I think). If
> that's not working for you, please let me know. I tried to make this
> work correctly in the past, but personally use the dri drivers.
> --
> Dan

I just built mesa with :

make clean
git pull origin
./autogen.sh --with-driver=xlib

And I agree from the output from --help this should be the same as make

I tried a VTK test build against this mesa and I got this :


/home/kevin/mesa/lib/libOSMesa.so.7: undefined reference to

This VTK is built with :


I really do not understand this missing symbol business since :

$ nm mesa/lib/libOSMesa.so | grep _mesa_free_context_data
                 U _mesa_free_context_data
$ nm mesa/lib/libGL.so | grep _mesa_free_context_data
0000000000078030 t _mesa_free_context_data

$ nm /opt/Mesa-7.8.1/lib64/libOSMesa.so | grep _mesa_free_context_data
                 U _mesa_free_context_data
$ nm /opt/Mesa-7.8.1/lib64/libGL.so | grep _mesa_free_context_data
0000000000092bc0 T _mesa_free_context_data

The symbol is defined in the same library in mesa built from the git
repo with autogen.sh --with-driver=xlib and in mesa built from the
release tarball with make linux-x86-64.

One VTK fails to build one VTK passes most tests :


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 253 bytes
Desc: OpenPGP digital signature
URL: <http://lists.freedesktop.org/archives/mesa-dev/attachments/20100510/e20d5d56/attachment.pgp>

More information about the mesa-dev mailing list