[Mesa-dev] Mesa (master): configs: Add -lstdc++ to default.

Gregory Prisament greg at lycheesoftware.com
Wed Sep 15 20:11:05 PDT 2010

I just ran into a situation where GLES2 context creation was failing.
Upon digging into it, I found that dlopen of st_GLESv2.so was failing
with "undefined symbol: __cxa_pure_virtual".

I found this thread, and realized that if I use g++ to compile my app,
it works.  However, if I use gcc it does not (for the reason above).

It'd be nice if C programs could work with Mesa's GLES2 without being
compiled as C++.  I'm not sure how to fix it so that both gcc and g++
work.  Maybe someone with a better understanding of what's going on
could chime in?

For now using g++ is a fine work-around.

-Greg Prisament, Lychee Software

ps: I tried reverting the patch above to see if it would help, but
dlopen still fails, this time with: "undefined symbol:

On Tue, Aug 24, 2010 at 11:45 AM, Brian Paul <brianp at vmware.com> wrote:
> On 08/24/2010 12:17 PM, Vinson Lee wrote:
>>> -----Original Message-----
>>> I missed this message/commit while I was away.
>>> The attached patch is how I would fix this problem.
>>> Vinson, can you try reverting your patch and trying this change?
>>> There may be other Makefiles where this change might be needed.
>> I'm tried reverting and applying the attached patch locally. glxinfo and
>> glxgears work on both swrast and softpipe.
>> .
> OK, go ahead and commit those changes then.
> -Brian
> _______________________________________________
> mesa-dev mailing list
> mesa-dev at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/mesa-dev

More information about the mesa-dev mailing list