[Mesa-dev] [Bug 30203] Mesa 7.8.3-rc1 fails to compile

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Sep 15 22:02:42 PDT 2010


Chia-I Wu <olvaffe at gmail.com> changed:

           What    |Removed                     |Added
             Status|NEW                         |RESOLVED
         Resolution|                            |FIXED

--- Comment #7 from Chia-I Wu <olvaffe at gmail.com> 2010-09-15 22:02:42 PDT ---
(In reply to comment #6)
> (In reply to comment #5)
> > 
> > Can you show me the result of executing "pkg-config --libs x11" on your system?
> >  Also, you may want to upgrade your autoconf, pkg-config, and libx11-dev and
> > see if it helps?
> > 
> pkg-config --libs x11
> -lX11  
> As I am using (upgraded) Debian/Sid autoconf and pkg-config are the latest
> Debian versions. 
> Installing the git master branch version of libx11 did not help.
> Because I was compiling with gcc4.5 v.4.5.1-7 (Debian/Experimental) I tried
> reverting to gcc4.4 (v.4.4.4-14) which solved the compilation problem!
It sounds like a version mismatch between the packages, but I am not sure how
that happens.  You may compare the results of running ./configure on both
compilers for hints.  I've committed the pthread patch and am closing this bug.

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the mesa-dev mailing list