[Mesa-dev] [Bug 33374] [bisect] FTBFS on commit 9767d3b5 (glapi: Fix OpenGL ES 1.1 and 2.0 interop)

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Mon Jan 24 19:15:58 PST 2011


--- Comment #2 from Dave Witbrodt <dawitbro at sbcglobal.net> 2011-01-24 19:15:58 PST ---
(In reply to comment #1)
> makedepend crashed when being executed in src/mapi/shared-glapi/.


> If your xutils-dev is not up-to-date, update it first.

Thanks for mentioning this.  I use Debian "unstable" which has the latest
packages available; I update frequently.  As it turns out, libc6 and xutils-dev
had just been updated.  My first assumption was that the bug was in one of
those updates and not in the Mesa sources.  After downgrading to the previous
version of xutils-dev (7.5+5) and two previous Debian releases of libc6 (all
versions were 2.11.2, but the Debian maintainers often add patches and release
new builds) I found that in all combinations of xutils-dev + libc6 that I tried
the crashing of makedepend only appeared with commit 9767d3b5... (and after),
but all prior commits that I tried during the bisect process worked fine.

This information was known to me when I posted the bug report, but I failed to
mention it because I wrongly assumed it was irrelevant.  The current version of
xutils-dev in Debian unstable is 7.6+1.

>  If it does not help, could you run makedepend manually and maybe change some
> of its options to see if the crash can be avoided?  You can see how mesa
> executes makedepend by removing the last "@" sign in
> src/mapi/shared-glapi/Makefile.

I haven't experimented with changing the options for makedepend yet.  I have
removed the "@" and captured the resulting output.  Here is the relevant part:

running /usr/bin/makedepend
/usr/bin/makedepend -fdepend -I/usr/lib/gcc/x86_64-linux-gnu/4.4.5/include
-I/usr/lib/gcc/x86_64-linux-gnu/4.4.5/include-fixed -f- -D_GNU_SOURCE
-I../../../include -I../../../src/mapi -DMAPI_MODE_GLAPI
-DMAPI_ABI_HEADER=\"shared-glapi/glapi_mapi_tmp.h\" \
        ../../../src/mapi/mapi/entry.c ../../../src/mapi/mapi/mapi_glapi.c
../../../src/mapi/mapi/stub.c ../../../src/mapi/mapi/table.c
../../../src/mapi/mapi/u_current.c ../../../src/mapi/mapi/u_execmem.c
../../../src/mapi/mapi/u_thread.c 2>/dev/null | sed -e
's,^../../../src/mapi/mapi/,,' \
        > depend
*** glibc detected *** /usr/bin/makedepend: double free or corruption (!prev):
0x000000000172a480 ***

It seems like makedepend should fail more gracefully in any case, so I should
file a bug report against it.  The options passed to 'configure' in my build
system are shown in my build output; have you succeeded in building Mesa at (or
after) commit 9767d3b5... using those options?  Is there something wrong with
that combination of options?  (My current build setup has been working for
nearly a month, so I'm assuming it's OK to use.)

If I have any success altering the options to makedepend, I will let you know. 
I will attach the entire output of the build I quoted above immediately
following this message.

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the mesa-dev mailing list