[Mesa-dev] [PATCH 3/4] queryobj: Add IsQuery flag, making ISQuery() return false before BeginQuery()

Matt Turner mattst88 at gmail.com
Wed Dec 19 20:17:51 PST 2012

On Mon, Dec 17, 2012 at 2:24 PM, Carl Worth <cworth at cworth.org> wrote:
> +   GLboolean IsQuery;  /**< query object is an actual query (see spec.) */

I don't mean to bikeshed this, but I'm doing this patch for the other
Is* functions and I'm thinking that Is* is a really bad name for this
field. Vertex array objects already have a _Used field, since ARB vs
Apple semantics are determined by which bind call is used. Can we come
up with a better naming convention? Maybe _Used/Used/EverBound or

More information about the mesa-dev mailing list