[Mesa-dev] [PATCH 1/3] mesa: rename _mesa_unpack_int_rgba_row() to _mesa_unpack_uint_rgba_row()
Brian Paul
brianp at vmware.com
Sat Jan 7 13:37:34 PST 2012
Since it returns uint values, not int.
---
src/mesa/main/format_unpack.c | 4 ++--
src/mesa/main/format_unpack.h | 4 ++--
src/mesa/main/readpix.c | 2 +-
3 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/src/mesa/main/format_unpack.c b/src/mesa/main/format_unpack.c
index a22ff5a..c723e89 100644
--- a/src/mesa/main/format_unpack.c
+++ b/src/mesa/main/format_unpack.c
@@ -1770,8 +1770,8 @@ unpack_int_rgba_ARGB2101010_UINT(const GLuint *src, GLuint dst[][4], GLuint n)
}
void
-_mesa_unpack_int_rgba_row(gl_format format, GLuint n,
- const void *src, GLuint dst[][4])
+_mesa_unpack_uint_rgba_row(gl_format format, GLuint n,
+ const void *src, GLuint dst[][4])
{
switch (format) {
/* Since there won't be any sign extension happening, there's no need to
diff --git a/src/mesa/main/format_unpack.h b/src/mesa/main/format_unpack.h
index c5348d3..bab29f6 100644
--- a/src/mesa/main/format_unpack.h
+++ b/src/mesa/main/format_unpack.h
@@ -30,8 +30,8 @@ _mesa_unpack_rgba_row(gl_format format, GLuint n,
void
-_mesa_unpack_int_rgba_row(gl_format format, GLuint n,
- const void *src, GLuint dst[][4]);
+_mesa_unpack_uint_rgba_row(gl_format format, GLuint n,
+ const void *src, GLuint dst[][4]);
extern void
_mesa_unpack_rgba_block(gl_format format,
diff --git a/src/mesa/main/readpix.c b/src/mesa/main/readpix.c
index 38b9c64..0c0e539 100644
--- a/src/mesa/main/readpix.c
+++ b/src/mesa/main/readpix.c
@@ -273,7 +273,7 @@ slow_read_rgba_pixels( struct gl_context *ctx,
for (j = 0; j < height; j++) {
if (_mesa_is_integer_format(format)) {
- _mesa_unpack_int_rgba_row(rbFormat, width, map, (GLuint (*)[4]) rgba);
+ _mesa_unpack_uint_rgba_row(rbFormat, width, map, (GLuint (*)[4]) rgba);
_mesa_pack_rgba_span_int(ctx, width, (GLuint (*)[4]) rgba, format,
type, dst);
} else {
--
1.7.3.4
More information about the mesa-dev
mailing list