[Mesa-dev] [PATCH 04/15] intel: Refactor quantize_num_samples

Eric Anholt eric at anholt.net
Wed Jul 25 10:35:27 PDT 2012

Chad Versace <chad.versace at linux.intel.com> writes:

> Rename quantize_num_samples to intel_quantize_num_samples and change the
> first param from struct intel_context* to struct intel_screen*. The
> function will later be used by intelCreateBuffer, which is not bound to
> any context but is bound to a screen. Since the function now depends on
> the screen, move it to intel_screen.[ch].

intel_fbo seems like a good place for it as well -- we've got other
screen-dependent function scattered around.  I don't really care either
way, but I think I would have looked in intel_fbo.c first.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/mesa-dev/attachments/20120725/f2a1b7ca/attachment.pgp>

More information about the mesa-dev mailing list