[Mesa-dev] [PATCH v2 1/5] i965: Parameterize HiZ code to prepare for adding blitting.
Chad Versace
chad.versace at linux.intel.com
Fri May 11 12:31:17 PDT 2012
On 05/10/2012 11:21 AM, Paul Berry wrote:
> This patch groups together the parameters used by the HiZ functions
> into a new data structure, brw_hiz_resolve_params, rather than passing
> each parameter individually between the HiZ functions. This data
> structure is a subclass of brw_blorp_params, which represents the
> parameters of a general-purpose blit or resolve operation. A future
> patch will add another subclass for blits.
>
> In addition, this patch generalizes the (width, height) parameters to
> a full rect (x0, y0, x1, y1), since blitting operations will need to
> be able to operate on arbitrary rectangles. Also, it renames several
> of the HiZ functions to reflect the expanded role they will serve.
>
> v2: Rename brw_hiz_resolve_params to brw_hiz_op_params. Move
> gen{6,7}_blorp_exec() functions back into gen{6,7}_blorp.h.
> ---
> src/mesa/drivers/dri/i965/Makefile.sources | 1 +
> src/mesa/drivers/dri/i965/brw_blorp.cpp | 108 ++++++++++++++++++++
> src/mesa/drivers/dri/i965/brw_blorp.h | 122 +++++++++++++++++++++++
> src/mesa/drivers/dri/i965/gen6_blorp.cpp | 146 +++++++++++-----------------
> src/mesa/drivers/dri/i965/gen6_blorp.h | 43 +-------
> src/mesa/drivers/dri/i965/gen7_blorp.cpp | 87 +++++++----------
> src/mesa/drivers/dri/i965/gen7_blorp.h | 5 +
> 7 files changed, 335 insertions(+), 177 deletions(-)
> create mode 100644 src/mesa/drivers/dri/i965/brw_blorp.cpp
> create mode 100644 src/mesa/drivers/dri/i965/brw_blorp.h
This patch is
Reviewed-by: Chad Versace <chad.versace at linux.intel.com>
More information about the mesa-dev
mailing list