[Mesa-dev] [PATCH 08/17] glapi: Annotate XML with exec="{es, check}" for special GLES1 functions.

Paul Berry stereotype441 at gmail.com
Fri Nov 2 14:58:00 PDT 2012


On 2 November 2012 14:09, Ian Romanick <idr at freedesktop.org> wrote:

> On 11/01/2012 03:19 PM, Paul Berry wrote:
>
>> Future patches will use this annotation when code generating
>> _mesa_create_exec_table(), to determine which functions should be
>> dispatched to ES-specific implementations.  exec="es" indicates that
>> the ES-specific implementation has a name beginning with "_es_"
>> (e.g. _es_QueryMatrixxOES), and exec="check" indicates that the
>> ES-specific implementation has a name beginning with "_check_"
>> (e.g. _check_GetTexGenxvOES).
>>
>
> All of the _check_ nonsense should just go away.  In api_exec_es1.c, every
> single instance of _check_Foo is just a #define to _es_Foo.
>
> All of the fixed-point functions should be renamed from _es_Foox to
> _mesa_Foox.  The single-precision matrix functions (e.g., _es_Orthof)
> should similar treatment.
>
> As far as I can tell, that just leaves _es_RenderbufferStorageEXT,
> _es_TexGenf, _es_TexGenfv, and _es_GetTexGenfv with mangled ES1 names.
>
> The single special-case for GL_RGB565 in _es_RenderbufferStorageEXT should
> just be handled in renderbuffer_storage.
>
> The TexGen functions should just have an 'if (ctx->API == API_OPENGL_ES)'
> block at the top the defers to the special ES1 implementation.


So, in other words, if I'm understanding you correctly, if we rename all
the _es_ and _check_ functions to _mesa_..., and do some refactoring in the
case of RenderbufferStorageEXT, TexGenf, TexGenfv, and GetTexGenfv, we
could get rid of the exec="es" and exec="check" flavors entirely?

That seems fairly reasonable.  I'll give it a shot and see how it goes.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/mesa-dev/attachments/20121102/54987072/attachment.html>


More information about the mesa-dev mailing list