[Mesa-dev] [PATCH 2/6] build: Rename PIPE_LOADER_HAVE_XCB to HAVE_PIPE_LOADER_XCB.
Matt Turner
mattst88 at gmail.com
Thu Apr 25 12:02:06 PDT 2013
For consistency, since we already have HAVE_PIPE_LOADER_{SW,DRM}.
---
configure.ac | 2 +-
.../auxiliary/pipe-loader/pipe_loader_drm.c | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/configure.ac b/configure.ac
index 55ea13d..25e6518 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1907,7 +1907,7 @@ if test "x$enable_gallium_loader" = xyes; then
PKG_CHECK_MODULES([GALLIUM_PIPE_LOADER_XCB], [xcb xcb-dri2],
pipe_loader_have_xcb=yes, pipe_loader_have_xcb=no)
if test "x$pipe_loader_have_xcb" = xyes; then
- GALLIUM_PIPE_LOADER_DEFINES="$GALLIUM_PIPE_LOADER_DEFINES -DPIPE_LOADER_HAVE_XCB"
+ GALLIUM_PIPE_LOADER_DEFINES="$GALLIUM_PIPE_LOADER_DEFINES -DHAVE_PIPE_LOADER_XCB"
GALLIUM_PIPE_LOADER_LIBS="$GALLIUM_PIPE_LOADER_LIBS $GALLIUM_PIPE_LOADER_XCB_LIBS $LIBDRM_LIBS"
fi
fi
diff --git a/src/gallium/auxiliary/pipe-loader/pipe_loader_drm.c b/src/gallium/auxiliary/pipe-loader/pipe_loader_drm.c
index 6dedc41..339d7bf 100644
--- a/src/gallium/auxiliary/pipe-loader/pipe_loader_drm.c
+++ b/src/gallium/auxiliary/pipe-loader/pipe_loader_drm.c
@@ -35,7 +35,7 @@
#include <libudev.h>
#include <xf86drm.h>
-#ifdef PIPE_LOADER_HAVE_XCB
+#ifdef HAVE_PIPE_LOADER_XCB
#include <xcb/dri2.h>
@@ -133,7 +133,7 @@ static struct pipe_loader_ops pipe_loader_drm_ops;
static void
pipe_loader_drm_x_auth(int fd)
{
-#if PIPE_LOADER_HAVE_XCB
+#if HAVE_PIPE_LOADER_XCB
/* Try authenticate with the X server to give us access to devices that X
* is running on. */
xcb_connection_t *xcb_conn;
--
1.7.8.6
More information about the mesa-dev
mailing list